Back to overview
Maintenance
Customer Portal Maintenance
Jan 15 at 03:00pm CET
–
Jan 15 at 04:39pm CET
Affected services
Customer Portal
Resolved
Jan 15 at 04:39pm CET
The scheduled maintenance for the Customer Portal has been successfully completed
Affected services
Created
Jan 15 at 03:00pm CET
Our customer portal will be temporarily unavailable due to scheduled maintenance. The downtime is expected to last a few hours, and access will be restored as soon as the work is complete. We appreciate your patience while we make improvements.
Affected services